Who wants to beta test the new OUPower software?

If you have questions concerning any of this Website's functions, features or operations, please utilize this area. Technical problems or issues go here as well.

Postby nakros » Thu Aug 11, 2005 10:47 pm

Chris,

Spent a while tonight playing around and trying to break things. Added 50 nested directories, and while they messed up the front page a little bit (made it scroll a bit off horizontally), didn't break anything.

Manipulated URLs to change directory into different peoples names, non-existant names, etc.., but to no avil. Got a lot of "illegal directory" messages. Tried moving and deleting adam's and bob's files, but wouldn't allow me.

I did notice, that if you create a directory inside a directory (test1/test2, for instance), if you then go into test1 and try to "mv" test2 (in an attempt to change its name, for instance), it always gets bumped back up to your home directory. The only way to change a name of a file or directory within a directory is to "mv" it to "path/to/file/or/directory/new_name"
nakros
Regular Poster
 
Posts: 67
Joined: Wed Jul 13, 2005 12:32 pm
Location: Ottawa, Canada

Postby Chris » Thu Aug 11, 2005 11:42 pm

Hi Nakros,

Thank you for the thorough testing. I appreciate it greatly. The "messing up of the main page" is going to be fixed shortly.

I will be installing code that ONLY shows your name (which is your root level) along with the total number of pics in your project directories and an appropriate UPDATED message. This way you can't clutter up the main page no matter how many directories you make.

Regarding the move (mv) process. Yes that is by design. You must give the full path to the destination file just as you discovered. I toyed with it many different ways but this was the only way to keep things secure. It's a small price to pay for the ability to move/rename things so easily right from the interface. I show the path to you from the old name so you can copy/paste that into the new name if you're just doing a rename. :wink:
-Chris

OUPower.com Site Admin
User avatar
Chris
Site Admin
 
Posts: 458
Joined: Wed Jan 19, 2005 6:42 pm
Location: Lancaster, PA

Postby nakros » Fri Aug 12, 2005 8:48 am

Chris,

As a feature request, it would be nice to have a "rename" button as well, which keeps the image or directory at the same location, but simply renames it. Yeah, it's a small thing, but it would be handy, I would think (and not all that much code, depending, of course, on how it's all implemented)

Once again, great job on the code, Chris! It has *almost* inspired me to write a few CGI or PHP scripts for my website to make things easier to update. *almost* simply because after 8 or 10 hours a day of coding, the last thing I want to see when I get home is a computer . :roll: :lol:
nakros
Regular Poster
 
Posts: 67
Joined: Wed Jul 13, 2005 12:32 pm
Location: Ottawa, Canada

Postby Chris » Fri Aug 12, 2005 6:14 pm

Hey Nakros,

Sure I can work on a button to simply do that, it shouldn't be a big deal.

I found a bug with the (escape characters) before quotes, so due to the FIX now being implemented you'll see extra \ (backslash) characters in front of quotes.

You can update your items if you like, but these are going to be wiped anyway when we go live so no need to bother with it if you don't want to. I was just letting you know why the \'s showed up all of the sudden :)
-Chris

OUPower.com Site Admin
User avatar
Chris
Site Admin
 
Posts: 458
Joined: Wed Jan 19, 2005 6:42 pm
Location: Lancaster, PA

Re: Help plz

Postby Bob Boyce » Tue Oct 11, 2005 11:26 pm

cow826 wrote:Does any one know what is wrong here?


cow826, the advertising in your signature line is not allowed. You are making nonsense posts here for advertising purposes. Your original messages will be deleted, and if you wish to post here again, please remove the advertising links from your signature.
User avatar
Bob Boyce
Regular Poster
 
Posts: 867
Joined: Sun Jan 23, 2005 2:06 pm

Postby Loster » Wed Oct 19, 2005 7:31 am

Last time I tried, Directory traversal was possible in the project manager ..
I could only see pictures on different directories on the website .. But nonetheless, it gives the directory structure which is bad .

You filter * .. *
Loster has been banned from the OUPower.com forum effective 5/15/2007 11:45 EST

My apologies to any that he has offended.
-Chris (Site Admin)
Loster
Regular Poster
 
Posts: 260
Joined: Sat Jun 25, 2005 11:13 pm

Postby Loster » Wed Oct 19, 2005 7:32 am

http://oupower.com/index.php?dir=_Other ... llDown=yes

Works when DrillDown == yes.. Otherwise doesn't .
Loster has been banned from the OUPower.com forum effective 5/15/2007 11:45 EST

My apologies to any that he has offended.
-Chris (Site Admin)
Loster
Regular Poster
 
Posts: 260
Joined: Sat Jun 25, 2005 11:13 pm

Postby Loster » Wed Oct 19, 2005 7:35 am

I can't edit my msgs so here another one :

http://oupower.com/index.php?dir=_Other ... llDown=yes

/.. shouldn't be allowed ..
Loster has been banned from the OUPower.com forum effective 5/15/2007 11:45 EST

My apologies to any that he has offended.
-Chris (Site Admin)
Loster
Regular Poster
 
Posts: 260
Joined: Sat Jun 25, 2005 11:13 pm

Postby Chris » Mon Oct 24, 2005 8:14 am

Not sure what bug you're referring to here. Can you please elaborate more thoroughly in the Project Owners forum. Somewhere not so public :)

I tried your links but they fail as well as any variant I tried.
-Chris

OUPower.com Site Admin
User avatar
Chris
Site Admin
 
Posts: 458
Joined: Wed Jan 19, 2005 6:42 pm
Location: Lancaster, PA

Previous

Return to Website Operations

Who is online

Users browsing this forum: No registered users and 1 guest

cron